Inicio > Mis eListas > nave > Mensajes

 Índice de Mensajes 
 Mensajes 7842 al 7861 
AsuntoAutor
Re: Otra duda srxo1978
Re: Otra duda Carlos
Re: Otra duda srxo1978
Una pregunta srxo1978
Re: Una pregunta Oscar Ma
Problemas con exte srxo1978
Re: Problemas con Oscar Ma
Re: Problemas con srxo1978
Re: Problemas con srxo1978
Re: Problemas con Carlos
Re: Problemas con srxo1978
Re: Problemas con Oscar Ma
Re: Problemas con srxo1978
Susto Thunderbird knocte
Re: Susto Thunderb Oscar Ma
Re: Susto Thunderb knocte
Problemas entre Mo El Kommo
Re: Problemas entr Ricardo
Sobre SeaMonkey 1. Ricardo
Re: Problemas entr stripTM
 << 20 ant. | 20 sig. >>
 
Proyecto NAVE
Página principal    Mensajes | Enviar Mensaje | Ficheros | Datos | Encuestas | Eventos | Mis Preferencias

Mostrando mensaje 7874     < Anterior | Siguiente >
Responder a este mensaje
Asunto:Re: [nave] Problemas con extension
Fecha:Martes, 24 de Enero, 2006  16:39:18 (+0100)
Autor:srxo1978 <srxo1978 @.....com>
En respuesta a:Mensaje 7873 (escrito por Oscar Manuel Gómez Senovilla)

Oscar Manuel Gómez Senovilla escribió:
> La primera duda es el archivo version.cfg :
>> Tengo puesto esto:
>>
>> if [ "$(get_value $SM $VALUE)" = 1 ]; then
>>  # Set these to appropiate value
>>  set_value $SM $MIN_VERSION "0.9"
>>  set_value $SM $MAX_VERSION "1.0"
>> fi
>>
>> if [ "$(get_value $FL $VALUE)" = 1 ]; then *si lo dices por la manera de ponerlo me dijieron que cambiase lo que pone en nave y poner esto
>>  # Set these to appropiate value			Me refiero a lo if etc..
>>  set_value $FL $MIN_VERSION "1.0+"
>>  set_value $FL $MAX_VERSION "1.0+"
>> fi
>>     
>
>
> ¿Ein? No te inventes variables, por favor :) En el fichero version.cfg
> sólo hay que cambiar los valores de las versiones, no añadir cosas
> nuevas (de momento), así que los resultados son impredecibles.
>   
Que lo dices por lo de FL  jeje *
lo puse por que en la extension original pone que es compatible y en el 
install.rdf original pone un total de 6 programas
 <!-- Firefox -->   
    <em:targetApplication>
     <Description>
       <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
       <em:minVersion>1.0</em:minVersion>
       <em:maxVersion>1.5.0.*</em:maxVersion>
     </Description>
    </em:targetApplication>   

    <!-- Thunderbird -->   
    <em:targetApplication>
      <Description>
        <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
        <em:minVersion>1.0</em:minVersion>
        <em:maxVersion>1.5.0.*</em:maxVersion>
      </Description>
    </em:targetApplication>  

    <!-- Flock -->
    <em:targetApplication>
      <Description>
        <em:id>{a463f10c-3994-11da-9945-000d60ca027b}</em:id>
        <em:minVersion>1.0+</em:minVersion>
        <em:maxVersion>1.0+</em:maxVersion>
      </Description>
    </em:targetApplication>
  
    <!-- Netscape -->
    <em:targetApplication>
       <Description>
         <em:id>{3db10fab-e461-4c80-8b97-957ad5f8ea47}</em:id>
         <em:minVersion>8.0</em:minVersion>
         <em:maxVersion>8.0.4</em:maxVersion>
       </Description>
    </em:targetApplication>
   
    <!-- Mozilla -->
    <em:targetApplication>
       <Description>
         <em:id>{86c18b42-e466-45a9-ae7a-9b95ba6f5640}</em:id>
         <em:minVersion>1.4</em:minVersion>
         <em:maxVersion>1.7.7</em:maxVersion>
       </Description>
    </em:targetApplication>   
   
    <!-- Seamonkey -->
    <em:targetApplication>
       <Description>
         <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
         <em:minVersion>0.9</em:minVersion>
         <em:maxVersion>1.0</em:maxVersion>
       </Description>
    </em:targetApplication>  

> Ya que es compatible con
> Thunderbird,Firefox,Flock,Seamonkey,Netscape,Mozilla. La duda es esta
> correcto.
>   

> No hay soporte para Flock, aparte de que habría que ver cuál es su
> identificador.
>
>   
>> La segunda duda es el archivo install.js.sed, yo he cogido la plantilla
>> de nave y he modificado esto:
>> // product related settings
>> // you can change these
>> const myProductName = "@EXT_BRAND_NAME@";
>> const myProductRegKey = "@EXT_NAME@";
>> const myProductRegVersion = "@EXT_VERSION@";
>>     
> ...
>   
>> Estaria correcto? ya que es la primera vez que uso el install.js.sed y
>> mi segunda extensión.
>>     
>
>
> Pues ni sí ni no, sino todo lo contario. El fichero install.js(.sed) es
> un fichero en javascript, del cual nunca ha habido un estándar y
> seguramente en pocos meses, si seamonkey se afianza e implementa bien el
> toolkit, los install.js desaparecerán (eso tengo entendido) usando
> únicamente el install.rdf. La única manera de saber si está bien es
> probarlo y ver si funciona, teniendo como referencia en caso de
> problemas el install.js del paquete en inglés.
>
>   
La duda es si lo me podeis orientar en como debo ponerlo con un ejemplo

> El tema del chrome.manifest todavía no está demasiado implementado (por
> eso el script no lleva ningún tipo de soporte), y casi me atrevería a
> decir que no es imprescindible a día de hoy, así que para salir del
> paso, intenta que concurden los ficheros y ve probando.
>
>   
Este tema lo tengo solucionado de mometo aunque  no lo he probado, merci 
carlos
> Para el sitio original, pues es preferible que el resultado ponga
> "Proyecto NAVE" en algún sitio, como por ejemplo <em:contributor>Pepe
> Pérez (Proyecto NAVE)</em:contributor>, para que se sepa el nombre a
> quien se escribe en caso de necesitar algo. Para el paquete de NAVE,
> sólo "Proyecto NAVE".
>
>   
Admitirian (Proyecto NAVE) srxo1978
> ¿Pero te funcionó bien al final la otra? En ese caso, deberías repasar
> qué fallos tuviste y así ya lo tienes aprendido para las siguientes.
Si que me funciono pero solo era para ff y no necesitaba mucha 
complicacion piensa que era para empezar
>
> No creas que te vas a librar de documentar la extensión por eso :)
>   
Documentar el que? jejeje


-~--------------------------------------------------------------------~-

-~--------------------------------------------------------------------~-
         Compra o vende de manera diferente en www.egrupos.net