Inicio > Mis eListas > nave > Mensajes

 Índice de Mensajes 
 Mensajes 7646 al 7665 
AsuntoAutor
Re: Plugins de bus stripTM
Re: Mozilla Firefo stripTM
Petición de revisi knocte
Re: Plugins de bus Nukeador
Re: Plugins de bus stripTM
Nueva =?ISO-8859-1 =?ISO-88
Re: Nueva =?ISO-88 Carlos
Re: Nueva =?ISO-88 =?ISO-88
Ayuda con tinderbo Diavolo
Re: Nueva =?ISO-88 =?ISO-88
Re: Ayuda con tind Guillerm
.....hola... stripTM
Re: .....hola... Ricardo
Re: .....hola... Oscar Ma
Asociar tipos de a Josemi
Re: Asociar tipos Ricardo
Thunderbird 1.5 RC Nukeador
Re: Thunderbird 1. stripTM
Re: Menus cortados stripTM
Re: Menus cortados Ricardo
 << 20 ant. | 20 sig. >>
 
Proyecto NAVE
Página principal    Mensajes | Enviar Mensaje | Ficheros | Datos | Encuestas | Eventos | Mis Preferencias

Mostrando mensaje 7678     < Anterior | Siguiente >
Responder a este mensaje
Asunto:Re: [nave] Nueva =?ISO-8859-15?Q?versi=F3n_del_script_para?= =?ISO-8859-15?Q?_extensiones?=
Fecha:Martes, 1 de Noviembre, 2005  10:18:22 (+0100)
Autor:=?ISO-8859-15?Q?Oscar_Manuel_G=F3mez_Senovilla?= <omgs @.............org>
En respuesta a:Mensaje 7676 (escrito por =?ISO-8859-15?Q?Oscar_Manuel_G=F3mez_Senovilla?=)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Oscar Manuel Gómez Senovilla escribió:
> Carlos escribió:
> 
> 
>>>Otra cosa, en las versiones más actuales de las extensiones suelen
>>>aparecer también las 2 siguientes líneas en el install.rdf:
>>>
>>><em:extension>true</em:extension>
>>><em:type>2</em:type>


He estado mirando
http://developer.mozilla.org/en/docs/Install_Manifests, y sobre "type" dice:

"This property was added for Firefox 1.5, and is only required for addon
types other than Extensions and Themes", es decir, que no es obligatorio
(he probado con linky 2.7.1 y no he tenido problemas para instalarla),
pero tampoco está de más, así que lo añadiré en el próximo script.

Sobre "extension" no he encontrado nada, ni siquiera en google, así que
 salvo que el autor proporcione un buen motivo, creo que no es buena
idea añadirlo.


Quiero comentar que, según el propio documento, el formato de los EID
para las extensiones pasará a ser nombre@... (en nuestro caso, sería
nombre at nave.escomposlinux.org). He estado haciendo pruebas
readaptando linky para actualizar de la 2.6.0-> 2.7.1, y aunque la
extensión se instala manualmente sin problemas (se crea el directorio
tipo nombre@... l perfil col con la extensión), a la hora de
actualizar, no ha habido manera (he modificado el sistema de
actualizaciones para este tercer formato, así que podeis ver manualmente
el resultado del rdf generado con la misma url, por si hubiera cometido
algún error), diciendo que no existía actualización disponible. Si
cambio al sistema de EID tradicional, la actualización funciona
perfectamente. He estado más de dos horas comiéndome el tarro y, de
momento, lo dejo por imposible. Por ello, creo que es mejor seguir con
el sistema actual usando UUID para los EID mientras no funcione esto.

Para implementar esto, no habría que tocar nada en vuestra parte, ya que
modificaría el script para bien generar dos secciones Description en el
install.rdf,  una con el formato actual para tener compatibilidad con
los EID anteriores, y otra con la nueva nomenclatura. Esto se mantendría
un tiempo hasta la 2.0 (calculo, y si no hay más cambios en este
sentido), en donde ya se quedaría la nomenclatura única de
nombre@... Se inría qría que las instalaciones nuevas (=que no sean
actualizaciones de un UUID) ya se quedaran con el nuevo EID de tipo
nombre@...

Por todo ello, y como <em:type> no es necesario, dejo el script como
está a la espera de que todo esto funcione, y pasaría a implementarlo.


Saludos.

- --

|----------------------------------------------------------------------|
| http://counter.li.org info: Linux user: 92390 - Linux machine: 39301 |
|     Oscar Manuel Gómez Senovilla - mailto:omgs@...     |
|               GPG Key at http://pgp.escomposlinux.org                |
|----------------------------------------------------------------------|
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFDZzLeQpr3kykd/aQRAlv8AJ9tk+nEnh/odbPKK1x6zuVwlj9grACggsTg
acWIVAjfuL/uYEusTTAHjAQ=
=fSSH
-----END PGP SIGNATURE-----

-~--------------------------------------------------------------------~-

-~--------------------------------------------------------------------~-
         Compra o vende de manera diferente en www.egrupos.net